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1. Analysis

1.1 Partial Factor based on Euro Code(2D Only)

 Static/Slope Analysis > Construction Stage > Partial Factor

 Partial factor which is derived from Euro Code (EN1997-1 Annex A) can be applied on the 2D model.
(Partial factor will be considered to materials which is containing the cohesion and friction angle and construction stage analysis with stress type)

MODS

[Partial Factor – Partial Factor] [Partial Factor – Material] [Partial Factor – Loads]
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- Partial FactorImport database: Values of partial factor for permanent load / variable load / soil materials can be defined from database or those values can be 

defined as user define. it will be indicated on the partial factor window whether apply the factors for load and soil materials.

- Material needs to be selected under this tab. It can be compared between original and factored properties from partial factor window.

- Factor will apply to selected load set.

1. Analysis

 DA1, C1: Partial factor will apply to load only.

 DA1, C2: Partial factor will apply to load and soil material.

 DA2: DA2 is similar with DA1, C1. But, the factors for pile and footing are different.

 DA3: DA3 is similar with DA1, C2. But, the factor for load (Unfavorable under Variable) is different.

MODS

1.1 Partial Factor based on Euro Code(2D Only)

 Partial factor which is derived from Euro Code (EN1997-1 Annex A) can be applied on the 2D model.
(Partial factor will be considered to materials which is containing the cohesion and friction angle and construction stage analysis with stress type)

 Static/Slope Analysis > Construction Stage > Partial Factor

Values of

Partial Factor

Permanent Variable Soil

Fav. Unfav. Fav. Unfav.
Effective Cohesion

(c)
tan Φ’

Undrained 

Strength

(su)

Eurocode 7 - DA1, C1 1.000 1.350 1.000 1.500 1.000 1.000 1.000

Eurocode 7 - DA1, C2 1.000 1.000 1.000 1.300 1.250 1.250 1.400

Eurocode 7 - DA2 1.000 1.350 1.000 1.500 1.000 1.000 1.000

Eurocode 7 - DA3 1.000 1.350 1.000 1.500 1.250 1.250 1.400
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1. Analysis

 Static/Slope Analysis > Construction Stage > Stage Set > Define Con...

[Define Construction Stage]

 Analysis > Analysis Case > General > Analysis Control > Nonlinear

[Analysis Control]

 Partial factor will be defined with construction stage analysis which is containing the stress analysis and this construction stage can make sub-stage.

 Sub-stage will be defined with stage name and partial factor which is created in partial factor function. The name of sub-stage will be specified with “name of 

construction stage_name of sub-stage”.

 Partial factor can be defined under 

analysis control and it will be applied to 

every construction stage. But, User 

needs to define partial factor for sub-

stage manually.

 EX) PF1 (Partial Factor 1) is applied 

from analysis control, PF2 (Partial 

Factor 2) is applied from sub-stage.

Stage 1 (PF1)

↓ → Stage 1_1 (PF2)

Stage 2 (PF1)

Properties under PF1: Original Properties x PF1

Properties under PF2: Original Properties x PF2

1.1 Partial Factor based on Euro Code(2D Only)

 Partial factor which is derived from Euro Code (EN1997-1 Annex A) can be applied on the 2D model.
(Partial factor will be considered to materials which is containing the cohesion and friction angle and construction stage analysis with stress type)

MODS
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1. Analysis

1.2 Virtual Beam

 Mesh > Element > Create > Other > Virtual Beam

[Virtual Beam Creation]

 It is creating the virtual beam from 2D/3D element and will be expressed with diagram for the result of virtual beam. Force can be found from virtual beam force
after analysis with activating the mesh set of virtual beam under construction stage.

 3D plane will be created on the normal direction of created virtual beam and force will be got from Local Direction force Sum of element which is on the same
plane.

[Beam Element ‐1D]

[Shell Element – 2D] [Solid Element – 3D]

[Result of Virtual Beam]
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1. Analysis

1.3 Considering Elastic Zone from Pile Element

 Mesh > Prop./Csys./Func. > Material > Create > Interface and Pile > Pile

[Test Model]

 It is considering the elastic zone which is using the pile interface on the 1D beam element from 2D/3D model.
 There is plasticity without considering the elastic zone and will be occurred huge deformation. So, elastic zone will prevent to occur the plasticity in the area

considering diameter of pile.

[Plastic Area without Elastic Zone]

[Consider Elastic Zone]

[Plastic Area with Elastic Zone]

[Total Direction without Elastic Zone] [Total Direction with Elastic Zone]
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 The dilatancy angle and tensile strength have added to each joint. Also, Failure criteria of Mohr-Coulomb can be applied on intact.

1. Analysis

1.4 Improvement of Jointed Rock Mass

 Mesh > Prop./Csys./Func. > Material > Create > Orthotropic > Jointed Rock Mass

 Elastic modulus, Poisson’s Ratio, Cohesion, Frictional angle, Dilatancy angle and Tensile Strength are same as Mohr-

Coulomb model. 

 Method of definition for dip direction, dip degree and declination is same as Transversely Isotropic model. But, in this 

jointed rock mass model can define three joints and elastic anisotropic behavior will be defined by alpha 1 and alpha2 from 

joint1. Joint2 and Joint3 will define plastic failure only.

[intact parameter]

 - If it is check off the intact parameter. it will be same as previous Jointed Rock Mass model.

 - If it is check on the intact parameter. It needs to define cohesion, friction angle and dilatancy angle.
[Properties for Joined Rock Mass]

[Jointed Rock Mass] [Flowchart for Analysis]
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1. Analysis

Reference

 Jaeger’s(1960) analytical solution for the effect of a single joint plane of weakness

 Maximum stress from uniaxial compressive test, 𝜎௖

- 𝑁∅ ൌ ଵାୱ୧୬ ∅
ଵିୱ୧୬ ∅

𝑐 ∶ 𝐶𝑜ℎ𝑒𝑠𝑖𝑜𝑛, 𝑐௝ ∶ 𝐶𝑜ℎ𝑒𝑠𝑖𝑜𝑛 𝑜𝑓 𝑗𝑜𝑖𝑛𝑡, ∅௝: 𝐹𝑟𝑖𝑛𝑐𝑡𝑖𝑜𝑖𝑛 𝑎𝑛𝑔𝑙𝑒 𝑜𝑓 𝑗𝑜𝑖𝑛𝑡

𝛽 ∶ 𝐼𝑛𝑐𝑙𝑖𝑛𝑎𝑡𝑖𝑜𝑛 𝑜𝑓 𝑑𝑖𝑠𝑐𝑜𝑛𝑡𝑖𝑛𝑢𝑖𝑡𝑦 𝑠𝑢𝑟𝑓𝑎𝑐𝑒 𝑡𝑜 𝑝𝑟𝑖𝑛𝑐𝑖𝑝𝑎𝑙 𝑠𝑡𝑟𝑒𝑠𝑠

[Unit Model] [Pressure stress based on inclination of discontinuity surface]

fracture of
rock material

slip on plane of
weakness

45 ൅
∅௪
2

[Mohr‐Coulomb Model]

[Jointed Rock Model]

[Jointed Rock Model with Intact parameter]

 The dilatancy angle and tensile strength have added to each joint. Also, Failure criteria of Mohr-Coulomb can be applied on intact.

1.4 Improvement of Jointed Rock Mass
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1. Analysis

1.5 PM4Sand

`

 It is developed to scheme the liquefaction using plastic theory based on effective stress. It is expanded to analysis with non-linear implicit based on the

material model which is applied to liquefaction scheme using explicit method.

 Elastic: It is nonlinear elastic behavior changing the elastic modulus with effective pressure(P) under Elastic zone. It needs to be selected with linear elastic

or power law.

 Poisson’s ratio will not be changed with pressure and volume modulus of elasticity will be calculated as below (Isotropic is 

maintained),

[ PM4Sand 모델에 대한 참고문헌 ]
Boulanger, R.W., Ziotopoulou, K. (2017). PM4sand (version 3.1): A sand plasticity model for earthquake engineering applications. Report No. UCD/CGM-17/01, March, 
Boulanger_Ziotopoulou_PM4Sand_V31_CGM-17-01_2017.pdf, 112pp.

 Mesh > Prop./CSys./Func. > Material > Create > Isotropic > PM4Sand

 2 1
3(1 2 )

K G








1
2

,1
SRm

o A SR o b
A

p MG G p C
p M

              

[ PM4Sand]

Parameter Contents Description

Dr Relative Density

Pa Atmospheric Pressure 101.3kPa

hpo Contraction Rate Parameter ‐

 Fabric Effect: Considering the effect of shaking particles

 Post Shaking Reconsolidation: PM4Sand model is considering the reconsolidation after seismic based on nonlinear elastic. But 

it needs to be used the cyclic load after heavy seismic
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`

1. Analysis

Parameter Content Description

Plastic Parameters

m Yield Surface Parameter Default : 0.01

nb/nd Bounding/Dilatancy Surface Parameter

Φcv Constant Volume Friction Angle

Q, R Critical State Line Parameter 𝜉ோ ൌ 𝑅/ሼ𝑄 െ ln 100𝑝 𝑝஺⁄ ሽ െ 𝐷ோ

h0 Hardening Parameter ℎ଴ ൌ minሼ 0.25 ൅ 𝐷ோ 2, 0.3ሽ⁄

Ad0 Dilatancy Parameter Recommendation : 1.2~1.5

emax / emin Maximum/Minimum Void Ratio Default : 0.8 / 0.5

Fabric Effect Parameters

Cz Fabric Tensor Control Parameter Default : 250

CDR Rotated Dilatancy Surface Parameter

Cε Dilation Parameter Calibration Parameter 𝐷ோ ൏ 35, 5, 35 ൑ 𝐷ோ൑ 75, 5 → 1linearly decrease

Ckaf Effect of Fabric on Hardening Calibration 
Parameter

Zmax Max. Value that Fabric Tensor can Attain

Elastic Behavior

mSR Elastic Shear Modulus Stress Ratio Effect Exponent

CSR, O Elastic Shear Modulus Stress Ratio Effect Coefficient

G0 Elastic Shear Modulus Coefficient

Post Shaking Reconsolidation

Psed, O / Fsed, min Post Shaking Reconsolidation Effect Control Parameter 𝐹௦௘ௗ,௠௜௡ ൌ 0.04, 𝑃௦௘ௗ,௢ ൌ െ 𝑃௔௧௠ 5⁄[Advanced Parameters]
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MODS
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 It has added initial stiffness dependence method for Rayleigh damping process from damping force calculation.

1. Analysis

1.6 Rayleigh Damping Stiffness

 Analysis > General > Nonlinear Time History > Analysis Control > Dynamic

[Damping Definition]

[Unit Test]

 Analysis > General > Nonlinear Time History+SRM > Analysis Control > Dynamic

 Static/Slope Analysis > Construction Stage > Stage Set > Stress-Nonlinear Time History > Stage Type : Nonlinear Time History > Analysis Control > Dynamic

[Comparing the history result depending the time]
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1. Analysis

1.7 Pretension Type(Multi-Stage Prestressing)

 Static/Slope Analysis > Load > Prestress > Pretension Type

 For Prestress > Pretension type, the load can be added or replaced under construction stage.

 In case of pretension will analysis with external force. Previously, It is working with only add fucntion under the activation step. But, User can add or replace the pretension from 

this newer version.

[Pretension] [Total Displacement with Anchor pretension] [Axial Force with Anchor pretension]

1.8 Improvement of Mode Combination with Sign

 It has added the expression of sign for user convenience about the result from each ingredient.

 Option 1. Principal mode from each direction

 Option 2. Maximum mode (Absolute value)
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 It can be verified phreatic line and face from seepage analysis result and check this result with others.

2.1 Phreatic Line/Face

 Worktree > Results > Nodal Seepage Results > PHREATIC LINE/FACE 

[From Result Tree]

[Phreatic Line (2D)] [Phreatic Face (3D)]

[Total Head & Phreatic Line (Seepage Analysis)] [Displacement & Phreatic Line (Fully Coupled Anlaysis)]

2. Pre/Post Processing

[From Property Window]
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 The properties of saturated soil are inputted by test data and it is hard to conduct the test in real project due to the time and cost. From the newer version, the curve
can be made by void ration, specific gravity, density and reference grain distribution from curve of grain distribution.

2.2 Estimate Unsaturated Property

2. Pre/Post Processing

 Mesh > Prop./CSys/Func. > Function > Grain-Size Distribution Function

 Grain-size distribution function needs to be defined before input the function of saturated soil.

 Curve of grain-size distribution will be created automatically after input the Particle size and 

 Accumulative Rate of Transmission(Data from the test).

MODS
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2. Pre/Post Processing

 Mesh > Prop./CSys/Func. > Function > Unsaturated Property Function

[Estimation of Unsaturated Property]

 Soil-water characteristic curve can be made by grain-size distribution curve, selecting the estimation of unsaturated property from user 

define of moisture content data. 

※ Volumetric water content will be calculated as follow,

𝜃௩௜ ൌ 𝜒 ෎
𝑉௣௝

𝑉௕
;      𝑖 ൌ 1,2 … . 𝑛,

௝ୀଵ

௝ୀଵ

𝑉௩௜ ൌ ௐ೔
ఘೞ

𝑒 ;  𝑉௩௜: Particle Size, 𝑊௜ ∶ Rate of Transmission,

𝜌௦ ∶ Particle Density, 𝑒 ∶ Void Ratio

Matric Suction,
𝜓௜ ൌ 2𝑟𝑐𝑜𝑠∅/𝜌௪𝑔𝑟௜ 

𝑟௜ ൌ 𝑅௜ ሾ4𝑒𝑛௜
ଵିక /6ሿଵ/ଶ ; Radius of Void,

𝜉 ൌ  𝛽/ 𝑙𝑜𝑔 𝐷௧  ; 𝐷௧ ൒ 100𝜇𝑚,    𝛽/ 𝑙𝑜𝑔 100  ; 𝐷௧ ൏ 100𝜇𝑚 

MODS

 The properties of saturated soil are inputted by test data and it is hard to conduct the test in real project due to the time and cost. From the newer version, the curve
can be made by void ration, specific gravity, density and reference grain distribution from curve of grain distribution.

2.2 Estimate Unsaturated Property
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2. Pre/Post Processing

 Mesh > Prop./CSys/Func. > Function > Unsaturated Property Function

 This function is referring to “Estimation of Soil Water Characteristic Curve for Weathered Granite Soils Considering Structural Characteristics, Lee, Hyeji (KAIST), 2005”. It is 

getting the grain distribution based on the equation of grain distribution curve, correction factor is applied to Arya and Paris model to estimate the saturation curve for weathered 

granite soils.

[Estimation of Unsaturated Property]

MODS

 The properties of saturated soil are inputted by test data and it is hard to conduct the test in real project due to the time and cost. From the newer version, the curve
can be made by void ration, specific gravity, density and reference grain distribution from curve of grain distribution.

2.2 Estimate Unsaturated Property
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 SRC(Steel Reinforced Concrete) can be defined under 1D element(truss, beam, embedded truss, embedded beam).

2. Pre/Post Processing

2.3 SRC Section DB

 Mesh > Prop.Csys/Func. > Property > Create > 1D > Beam > Section

[Section Template]

 Steel Data: Input the parameter of steel section or selecting the section from database.

 Concrete Data: Input the outer dimensions of section for steel concrete

 Material: Select the material for SRC or input the parameters. The parameters will be inputted 

automatically selecting the database from [Select Material from DB…].

 Es/Ec: Elastic ratio between steel and concrete

 Ds/Dc: Deadweight ratio between steel and concrete

 Ps: Poisson’s ratio of steel

 Pc: Poisson’s ratio of concrete

 Conv. Stiffness Factor: Stiffness reduction factor of concrete (default=1.0) for SRC section

[ Rect‐HBeam ] [ Circle‐HBeam ]

[ SRC‐Box ] [ SRC‐Pipe ]

[Material Property]



19 / 24

GTSNX 2020(v1.1)  Release NoteGTSNX  2020(v1.1) Enhancement

 It is calculating the torsional stress coefficient, effective shear area and shear stress coefficient automatically from selecting the database of H section, r1/r2 can be
inputted additionally.

2. Pre/Post Processing

2.4   Automatically Calculation of H Section

 Mesh > Prop.Csys/Func. > Property > Create > 1D > Beam > Section

Ver. 2019 Ver. 2020

[H Section from GTS NX 2019] [H Section from GTS NX 2020]
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2.5   Control the Artificial Earthquake

2. Pre/Post Processing

 Random Seed can apply to get same artificial earthquake.

 Dynamic Analysis > Tools > Artificial Earthquake

ωn = Frequency, An = Amplitude, Фn = Phase Angle, I(t) =  Envelope Fucntion

)cos()()(
1




N

n
nnn tAtItz 

Envelope Function: It will be calculated acceleration time history using below equation to make the 

acceleration time history equivalent response spectrum.

[Add/Modify Artificial Earthquake]

[Envelope Funtion]

 Max. Iterations: The number of maximum iterations work to make the match between the result of response 

spectrum and imputed response spectrum of artificial earthquake.

 Max. Acceleration: To define the maximum earthquake acceleration of artificial earthquake.

 Damping Ratio: To define the damping ratio for calculating of response spectrum from artificial earthquake.

 Random Seed: To define the random seed for calculating the response spectrum from artificial 

earthquake(Artificial positive value).

 Generate Acceleration: To generate the acceleration data from response spectrum data. 

 Spectrum Graph: To verify the data of acceleration based on spectrum data. 

 Acceleration Graph: To verify the graph based on the acceleration data. 

MODS

I(t)

Rise Time
Total Time

Level Time

Envelope function will be multiplying to steady stage motion for transient of real seismic and this 

function can be divided to trapezoidal, compound and exponential. Acceleration time history will be 

almost same value from start to end without this envelope function.
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 It has improved the loft function with new method. Loft function can use to section with hole.
 (Previous method: direct loft between models, Newer version: lofting with center between models)

2.6   Improvement of Loft Function

 Geometry > Protrude > Loft

2. Pre/Post Processing

Ver. 2019 Ver. 2020Geometry

Loft N/A
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 The location of arrow from dynamic nodal load can be controlled. It can select Start, Middle, End position.

2.7   Label Location of Dynamic Nodal Load

2. Pre/Post Processing

 Tools > Options > Loads/B.C > Dynamic Nodal Load

 If there are many subcase under post tree, the post function will work slowly so that it has improved.
 The subcase will check off as a default after analysis. It needs check on to see the stage result.

2.8   Improvement of Stage Bar from Post

[Dynamic Nodal Load] [Position: Start] [Position: Middle] [Position: End]

[Stage Bar] [Subcase]
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 Prescribe strain can be applying to linear static analysis, nonlinear static analysis, consolidation analysis and fully coupled analysis as well.
 There is no strain component of z direction so that it has eliminated.

2.9   Improvement of Prescribe Strain(Volumetric Strain)

 Plastic Hardening Function and Frictional Angle Hardening Curve are similar so that it has unified.
1) Mesh > Prop./CSys./Func. > Function > Plastic Hardening Curve Deleted
2) Nonlinear tab from MMC model > Friction Angle at shear > Hardening Function > Name has changed from Plastic Hardening Function to Frictional Angle
Hardening Curve.
3) Hardening Curve’s table: Plastic Strain -> Equivalent Plastic Strain

2.11 Words Amendment from Plastic Hardening Function

2.12 The Output of 2D Equivalent Linear Analysis

2. Pre/Post Processing

 The error message has updated more correctly under stress-seepage analysis. The construction stage need to be constituted seepage analysis first under stress-
seepage analysis. This stress-seepage analysis will be calculated pore pressure from seepage analysis to stress analysis.

 ex) step 1. Seepage or Stress > step 2. Stress(Deactivate mesh & LDF) > step 3. Seepage (about step 2) > Step 4. Stress ← Analysis N/A

 Step of LDF will be counted under stress stage only from stress-seepage analysis.

2.10 Improvement of Applying LDF

 In case of 1 from all output step and step will be provided the history graph without considering Intermediate output of time step from the 2D equivalent linear
analysis

 History graph contains interval of step and time under selecting the frequency of history output probes.
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 DataMine SW(MicroMine, Leapfrog, etc.) model file can be converting to GTS NX file.

2.13 Mining Model Converter 

2. Pre/Post Processing

[ 3D Face ]

[ Model Block ]

[ 3D Face Mesh ] [ 3D Solid Mesh ]

 Mining data type: Type can be selected from 3D Face and Model Blocks. 3D Face type can import dxf. file. Model Block type can 

import csv file.

 Directory: Directory for information of model file and define save folde.

 Convert: It is creating the GT NX file(fpn.) after converting. This converted file can be imported to GTS NX from Main Menu > 

Import > GTSNX Neutral Format.

[ Block Model(Leapfrog) ] [ Block Model(GTSNX) ]

 Main Menu > Import > Execute Mining Model Convert


